Checks whether automatic landing(s) can be created between the given two stairs runs and logically join(s) with the stairs runs.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document that owns the stairs runs.
- firstRunId
- Type: Autodesk.Revit.DBElementId
The first stairs run.
- secondRunId
- Type: Autodesk.Revit.DBElementId
The second stairs run.
Return Value
True if automatic landing(s) can be created between the two stairs runs, False otherwise.Remarks
This only checks whether two stairs runs meet restriction to create automatic landing(s) without checking the stairs edit scope and document modifiable.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |