Stairs |
Checks whether automatic landing(s) can be created between the given two stairs runs and logically join(s) with the stairs runs.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static bool CanCreateAutomaticLanding(
Document document,
ElementId firstRunId,
ElementId secondRunId
)
Parameters
- document Document
- The document that owns the stairs runs.
- firstRunId ElementId
- The first stairs run.
- secondRunId ElementId
- The second stairs run.
Return Value
BooleanTrue if automatic landing(s) can be created between the two stairs runs, False otherwise.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

This only checks whether two stairs runs meet restriction to create automatic landing(s) without checking the stairs edit scope and document modifiable.