Set the normal of plane in which the hook at end of bar with index barPositionIndex will stay. This information is set to the rebar after the API execution is finished successfully.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- end
- Type: SystemInt32
The end of bar. Should be 0 for start or 1 for end.
- barPositionIndex
- Type: SystemInt32
Index of the bar for which it will set hook plane normal.
- hookNormal
- Type: Autodesk.Revit.DBXYZ
The normal of plane in which the hook at end of bar with index barPositionIndex will stay.
Remarks
This information is set to the rebar after the API execution is finished successfully. Before setting the value a validation will be done. We consider a hook plane normal valid if it isn't parallel with the bar direction at end.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | Invalid end. -or- hookNormal has zero length. |