SetHookPlaneNormalForBarIdx Method


Rebar Update Curves Data Set Hook Plane Normal For Bar Idx Method

Note: This API is now obsolete.

Sets the plane's normal in which the termination at end of bar with index barPositionIndex will stay. The normal will be used for both hook and crank. This information is set to the rebar after the API execution is finished successfully.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
[ObsoleteAttribute("This method is deprecated in Revit 2026 and may be removed in a later version of Revit. Please use RebarUpdateCurvesData.SetTerminationPlaneNormalForBarIdx instead.")]
public void SetHookPlaneNormalForBarIdx(
	int end,
	int barPositionIndex,
	XYZ terminationPlaneNormal
)

Parameters

end Int32
The end of bar. Should be 0 for start or 1 for end.
barPositionIndex Int32
Index of the bar for which it will set the termination's plane normal.
terminationPlaneNormal XYZ
The plane's normal in which the termination at end of bar with index barPositionIndex will stay. The normal will be used for both hook and crank.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException Invalid end. -or- terminationPlaneNormal has zero length.
Remarks
This information is set to the rebar after the API execution is finished successfully. Before setting the value a validation will be done. We consider a termination plane normal valid if it's perpendicular with the bar direction at end.
See Also