GetGraphicOverrides Method (String)


Returns the graphic overrides assigned for elements owned by a particular user.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public WorksharingDisplayGraphicSettings GetGraphicOverrides(
	string username
)
Visual Basic
Public Function GetGraphicOverrides ( _
	username As String _
) As WorksharingDisplayGraphicSettings
Visual C++
public:
WorksharingDisplayGraphicSettings^ GetGraphicOverrides(
	String^ username
)

Parameters

username
Type: SystemString
The username of a particular user.

Return Value

The graphic overrides assigned to this user.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException This WorksharingDisplaySettings does not contain graphic overrides for the specified value of username.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also