Extends the multistory stairs by connecting input levels.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- levelIds
- Type: System.Collections.GenericISetElementId
The level ids.
Remarks
The added stairs will be categorized into different groups based on level heights automatically. Stairs with the same level height are considered a group and can be edited together. You cannot connect the levels between standard stairs top and bottom or already connected.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | This multistory stairs cannot connect to one or more members of levelIds. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |