ConnectLevels Method


Multistory Stairs Connect Levels Method

Extends the multistory stairs by connecting input levels.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void ConnectLevels(
	ISet<ElementId> levelIds
)

Parameters

levelIds ISet ElementId
The level ids.
Exceptions
Exception Condition
ArgumentException This multistory stairs cannot connect to one or more members of levelIds.
ArgumentNullException A non-optional argument was null
Remarks
The added stairs will be categorized into different groups based on level heights automatically. Stairs with the same level height are considered a group and can be edited together. You cannot connect the levels between standard stairs top and bottom or already connected.
See Also