Allows the wall's end to join to other walls. If that end is near other walls it will become joined as a result.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- wall
- Type: Autodesk.Revit.DBWall
The wall in question
- end
- Type: SystemInt32
0 or 1 for the beginning or end of the wall's curve
Remarks
By default all walls are allowed to join at ends, so this function is only needed if this wall end is already disallowed to join. If this wall is a stacked wall, all subwalls at this end will be allowed to join.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |