AllowWallJoinAtEnd Method


Wall Utils Allow Wall Join At End Method

Allows the wall's end to join to other walls. If that end is near other walls it will become joined as a result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static void AllowWallJoinAtEnd(
	Wall wall,
	int end
)

Parameters

wall Wall
The wall in question
end Int32
0 or 1 for the beginning or end of the wall's curve
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
By default all walls are allowed to join at ends, so this function is only needed if this wall end is already disallowed to join. If this wall is a stacked wall, all subwalls at this end will be allowed to join.
See Also