Returns one or more properties for legacy (created in R2012 or before) Stairs.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- exporterIFC
- Type: Autodesk.Revit.DB.IFCExporterIFC
The exporter.
- pElement
- Type: Autodesk.Revit.DBElement
the legacy stair.
- pNumRisers
- Type: SystemInt32%
Number of Risers in the Stair.
- pNumTreads
- Type: SystemInt32%
Number of Treads in the Stair.
- pRiserHeight
- Type: SystemDouble%
Riser Height of the risers in the Stair.
- pTreadLength
- Type: SystemDouble%
Tread length of the treads in the Stair.
- pMinTreadLength
- Type: SystemDouble%
Minimum Tread length of the treads in the Stair.
- pNosingLength
- Type: SystemDouble%
Nosing length of the treads in the Stair.
- pWaistThickness
- Type: SystemDouble%
Waist thickness of the flight of stair.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |