Exporter |
Returns one or more properties for legacy (created in R2012 or before) Stairs.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)

public static void GetLegacyStairsProperties(
ExporterIFC exporterIFC,
Element pElement,
out int pNumRisers,
out int pNumTreads,
out double pRiserHeight,
out double pTreadLength,
out double pMinTreadLength,
out double pNosingLength,
out double pWaistThickness
)
Parameters
- exporterIFC ExporterIFC
- The exporter.
- pElement Element
- the legacy stair.
- pNumRisers Int32
- Number of Risers in the Stair.
- pNumTreads Int32
- Number of Treads in the Stair.
- pRiserHeight Double
- Riser Height of the risers in the Stair.
- pTreadLength Double
- Tread length of the treads in the Stair.
- pMinTreadLength Double
- Minimum Tread length of the treads in the Stair.
- pNosingLength Double
- Nosing length of the treads in the Stair.
- pWaistThickness Double
- Waist thickness of the flight of stair.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |