NewSpaceBoundaryLines Method


Creates a new boundary line as an Space border.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ModelCurveArray NewSpaceBoundaryLines(
	SketchPlane sketchPlane,
	CurveArray curves,
	View view
)
Visual Basic
Public Function NewSpaceBoundaryLines ( _
	sketchPlane As SketchPlane, _
	curves As CurveArray, _
	view As View _
) As ModelCurveArray
Visual C++
public:
ModelCurveArray^ NewSpaceBoundaryLines(
	SketchPlane^ sketchPlane, 
	CurveArray^ curves, 
	View^ view
)

Parameters

sketchPlane
Type: Autodesk.Revit.DBSketchPlane
The sketch plan
curves
Type: Autodesk.Revit.DBCurveArray
The geometry curves on which the boundary lines are
view
Type: Autodesk.Revit.DBView
The View for the new Space

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentExceptionThrown if the sketch plane does not exist in the given document.
Autodesk.Revit.ExceptionsArgumentExceptionThrown if the view does not exist in the given document.

See Also