Document New |
Creates a new boundary line as an Space border.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public ModelCurveArray NewSpaceBoundaryLines(
SketchPlane sketchPlane,
CurveArray curves,
View view
)
Parameters
- sketchPlane SketchPlane
- The sketch plan
- curves CurveArray
- The geometry curves on which the boundary lines are
- view View
- The View for the new Space
Return Value
ModelCurveArray
Exception | Condition |
---|---|
ArgumentException | Thrown if the sketch plane does not exist in the given document. |
ArgumentException | Thrown if the view does not exist in the given document. |