Creates a new instance of an area based load and adds it to the document.
Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- doc
- Type: Autodesk.Revit.DBDocument
The document where the element will be created and added.
- name
- Type: SystemString
The name of the area based load to be created.
- levelId
- Type: Autodesk.Revit.DBElementId
The base level on which the area based load will be created.
- phaseId
- Type: Autodesk.Revit.DBElementId
The associative phase on which the area based load is to exist.
Return Value
The newly created area based load.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- name is an empty string. -or- The ElementId levelId is not a Level. -or- The id does not represent a valid phase. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsInvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). |
Autodesk.Revit.ExceptionsModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.ExceptionsModificationOutsideTransactionException | The document has no open transaction. |