CreateAreaBasedLoad Method


Zone Create Area Based Load Method

Creates a new instance of an area based load and adds it to the document.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static Zone CreateAreaBasedLoad(
	Document doc,
	string name,
	ElementId levelId,
	ElementId phaseId
)

Parameters

doc Document
The document where the element will be created and added.
name String
The name of the area based load to be created.
levelId ElementId
The base level on which the area based load will be created.
phaseId ElementId
The associative phase on which the area based load is to exist.

Return Value

Zone
The newly created area based load.
Exceptions
Exception Condition
ArgumentException name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- name is an empty string. -or- The ElementId levelId is not a Level. -or- The id does not represent a valid phase.
ArgumentNullException A non-optional argument was null
InvalidOperationException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
ModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException The document has no open transaction.
See Also