Creates multiple new paths of travel between same size sets of start and end points.
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- DBView
- Type: Autodesk.Revit.DBView
The floor plan view to use when computing the shortest distance.
- pathStarts
- Type: System.Collections.GenericIListXYZ
The start points of the path. The input Z coordinates are ignored and set to the view's level elevation.
- pathEnds
- Type: System.Collections.GenericIListXYZ
The end points of the path. The input Z coordinates are ignored and set to the view's level elevation.
Return Value
The array of newly created path of travel elements, or a null reference (Nothing in Visual Basic) if no path between the two points is found. The order of elements corresponds to the order of start/end points in the argument arrays. There are some additional conditions that are checked and if any condition is true the a null reference (Nothing in Visual Basic) value is returned:- View has crop box active and start or end point lies outside of the crop
- Start and end points are too close
Remarks
InvalidOperationException is thrown if PathOfTravel cannot be created for the following conditions:
- View has crop box active and crop box is split
- View model outline area is larger than the current limit (2,000,000 sq.ft.)
- View export contains too much geometry (more than 200,000 lines)
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The element "DBView" is in a family document or a document in in-place edit mode. -or- View is not a floor plan view. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsInvalidOperationException | The document containing DBView is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- This operation cannot be performed while the document is in edit mode. -or- The Path of Travel calculation service is not available -or- This functionality is not available in Revit LT. |
Autodesk.Revit.ExceptionsModificationForbiddenException | The document containing DBView is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document containing DBView is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.ExceptionsModificationOutsideTransactionException | The document containing DBView has no open transaction. |