Path |
Creates multiple new paths of travel between same size sets of start and end points.
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static IList<PathOfTravel> CreateMultiple(
View DBView,
IList<XYZ> pathStarts,
IList<XYZ> pathEnds
)
Parameters
- DBView View
- The floor plan view to use when computing the shortest distance.
- pathStarts IList XYZ
- The start points of the path. The input Z coordinates are ignored and set to the view's level elevation.
- pathEnds IList XYZ
- The end points of the path. The input Z coordinates are ignored and set to the view's level elevation.
Return Value
IList PathOfTravelThe array of newly created path of travel elements, or if no path between the two points is found. The order of elements corresponds to the order of start/end points in the argument arrays. There are some additional conditions that are checked and if any condition is true the value is returned:
- View has crop box active and start or end point lies outside of the crop
- Start and end points are too close

Exception | Condition |
---|---|
ArgumentException | The element "DBView" is in a family document or a document in in-place edit mode. -or- View is not a floor plan view. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | The document containing DBView is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- This operation cannot be performed while the document is in edit mode. -or- The Path of Travel calculation service is not available -or- This functionality is not available in Revit LT. |
ModificationForbiddenException | The document containing DBView is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document containing DBView is being loaded, or is in the midst of another sensitive process. |
ModificationOutsideTransactionException | The document containing DBView has no open transaction. |

InvalidOperationException is thrown if PathOfTravel cannot be created for the following conditions:
- View has crop box active and crop box is split
- View model outline area is larger than the current limit (2,000,000 sq.ft.)
- View export contains too much geometry (more than 200,000 lines)