Constructs a new ExternalResourceBrowserData using the given document(optional), server id, folder path and match options.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document for which the external resource browser data is requested. The document can be a null reference (Nothing in Visual Basic), if so, the getCallingDocumentModelPath() will not return ModelPath.
- serverId
- Type: SystemGuid
The id of IExternalResourceServer which handles the external resource browsing and loading.
- folderPath
- Type: SystemString
The folder path to which the external resources and subfolders belong.The folder separator should always be "/" and "/" always represents the root folder for the server.
The interpretation of what a folder represents is up to the server. For example, the folder "/English/Keynote" might be a physical folder on a disk, or a table or key in a database.
- matchOptions
- Type: Autodesk.Revit.DBExternalResourceMatchOptions
The options to match the external resources and folders.Generally, the returned resources should match the options, otherwise the resource may be regarded as invalid which may not be available in browser dialogs.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |