ExternalResourceBrowserData Constructor


External Resource Browser Data Constructor

Constructs a new ExternalResourceBrowserData using the given document(optional), server id, folder path and match options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ExternalResourceBrowserData(
	Document document,
	Guid serverId,
	string folderPath,
	ExternalResourceMatchOptions matchOptions
)

Parameters

document Document
The document for which the external resource browser data is requested. The document can be , if so, the getCallingDocumentModelPath() will not return ModelPath.
serverId Guid
The id of IExternalResourceServer which handles the external resource browsing and loading.
folderPath String
The folder path to which the external resources and subfolders belong.

The folder separator should always be "/" and "/" always represents the root folder for the server.

The interpretation of what a folder represents is up to the server. For example, the folder "/English/Keynote" might be a physical folder on a disk, or a table or key in a database.

matchOptions ExternalResourceMatchOptions
The options to match the external resources and folders.

Generally, the returned resources should match the options, otherwise the resource may be regarded as invalid which may not be available in browser dialogs.

Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also