Indicate if a ConceptualConstruction is appropriate to assign to a MassSurfaceData of a particular Mass subcategory.
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- ccda
- Type: Autodesk.Revit.DBDocument
The document.
- constructionTypeId
- Type: Autodesk.Revit.DBElementId
The ElementId of the ConceptualConstructionType.
- massSubcategoryId
- Type: Autodesk.Revit.DBElementId
The ElementId of the Mass subcategory.
Return Value
Returns true if valid, false otherwiseExceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The ElementId constructionTypeId is not an id of a ConceptualConstructionType. -or- The mass sub-category is none of the OST_MassInteriorWall, OST_MassExteriorWall, OST_MassExteriorWallUnderground, OST_MassWallsAll, OST_MassRoof, OST_MassFloor, OST_MassSlab, OST_MassFloorsAll, OST_MassShade, OST_MassGlazing, OST_MassSkylights, OST_MassGlazingAll or OST_MassOpening. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |