Conceptual |
Indicate if a ConceptualConstruction is appropriate to assign to a MassSurfaceData of a particular Mass subcategory.
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static bool IsValidConceptualConstructionIdForCategory(
Document ccda,
ElementId constructionTypeId,
ElementId massSubcategoryId
)
Parameters
- ccda Document
- The document.
- constructionTypeId ElementId
- The ElementId of the ConceptualConstructionType.
- massSubcategoryId ElementId
- The ElementId of the Mass subcategory.
Return Value
BooleanReturns true if valid, false otherwise

Exception | Condition |
---|---|
ArgumentException | The ElementId constructionTypeId is not an id of a ConceptualConstructionType. -or- The mass sub-category is none of the OST_MassInteriorWall, OST_MassExteriorWall, OST_MassExteriorWallUnderground, OST_MassWallsAll, OST_MassRoof, OST_MassFloor, OST_MassSlab, OST_MassFloorsAll, OST_MassShade, OST_MassGlazing, OST_MassSkylights, OST_MassGlazingAll or OST_MassOpening. |
ArgumentNullException | A non-optional argument was null |