SeparateReferencesIntoConnectedReferences Method


This function separates the input curve references into groups of connected curve references. Each group of connected curve references can be used to create a divided path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public static IList<IList<Reference>> SeparateReferencesIntoConnectedReferences(
	Document document,
	IList<Reference> curveReferences
)
Visual Basic
Public Shared Function SeparateReferencesIntoConnectedReferences ( _
	document As Document, _
	curveReferences As IList(Of Reference) _
) As IList(Of IList(Of Reference))
Visual C++
public:
static IList<IList<Reference^>^>^ SeparateReferencesIntoConnectedReferences(
	Document^ document, 
	IList<Reference^>^ curveReferences
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document.
curveReferences
Type: System.Collections.GenericIListReference
The references.

Return Value

The grouped references

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException Not all curve references in curveReferences represent a curve or an edge
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException this operation failed.

See Also