SeparateReferencesIntoConnectedReferences Method


Divided Path Separate References Into Connected References Method

This function separates the input curve references into groups of connected curve references. Each group of connected curve references can be used to create a divided path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static IList<IList<Reference>> SeparateReferencesIntoConnectedReferences(
	Document document,
	IList<Reference> curveReferences
)

Parameters

document Document
The document.
curveReferences IList Reference
The references.

Return Value

IList IList Reference
The grouped references
Exceptions
Exception Condition
ArgumentException Not all curve references in curveReferences represent a curve or an edge
ArgumentNullException A non-optional argument was null
InvalidOperationException this operation failed.
See Also