GetRodLength Method


Get the current rod length. If the rod is the length will include structural extension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2018

Syntax

C#
public double GetRodLength(
	int rodIndex
)
Visual Basic
Public Function GetRodLength ( _
	rodIndex As Integer _
) As Double
Visual C++
public:
double GetRodLength(
	int rodIndex
)

Parameters

rodIndex
Type: SystemInt32
The rod index.

Return Value

Returns rod length of hanger for specified end.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException the index rodIndex is should be in range of rod count.

See Also