IsValidSchemeName Method


Checks whether the name is valid for new generated scheme.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2022

Syntax

C#
public bool IsValidSchemeName(
	string name
)
Visual Basic
Public Function IsValidSchemeName ( _
	name As String _
) As Boolean
Visual C++
public:
bool IsValidSchemeName(
	String^ name
)

Parameters

name
Type: SystemString

Return Value

Returns true if the name is valid for new generated scheme, false otherwise.

Remarks

The name should not be empty, or all spaces, or include prohibited characters or duplicated with existing schemes.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also