GetCategoryOverrides Method


Gets graphic overrides for a category in view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public OverrideGraphicSettings GetCategoryOverrides(
	ElementId categoryId
)
Visual Basic
Public Function GetCategoryOverrides ( _
	categoryId As ElementId _
) As OverrideGraphicSettings
Visual C++
public:
OverrideGraphicSettings^ GetCategoryOverrides(
	ElementId^ categoryId
)

Parameters

categoryId
Type: Autodesk.Revit.DBElementId
Category to be checked.

Return Value

Object representing all graphic overrides of the category categoryId in view. A default OverrideGraphicSettings object will be returned if it not previously been set for this view.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException The view type does not support Visibility/Graphics Overriddes.

See Also