GetCategoryOverrides Method


View Get Category Overrides Method

Gets graphic overrides for a category in view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public OverrideGraphicSettings GetCategoryOverrides(
	ElementId categoryId
)

Parameters

categoryId ElementId
Category to be checked.

Return Value

OverrideGraphicSettings
Object representing all graphic overrides of the category categoryId in view. A default OverrideGraphicSettings object will be returned if it not previously been set for this view.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
InvalidOperationException The view type does not support Visibility/Graphics Overriddes.
See Also