ExternalResourceSubFolder Constructor (String, String)


Constructs a new ExternalResourceSubFolder with custom values for folder name and icon path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2019.1

Syntax

C#
public ExternalResourceSubFolder(
	string folderName,
	string iconPath
)
Visual Basic
Public Sub New ( _
	folderName As String, _
	iconPath As String _
)
Visual C++
public:
ExternalResourceSubFolder(
	String^ folderName, 
	String^ iconPath
)

Parameters

folderName
Type: SystemString
Folder displayed name.
iconPath
Type: SystemString
The path of the resource icon.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also