GetEdgeNumber Method


If the RebarConstrainedHandle's RebarHandleType is 'Edge', then this function will return the number of the edge that is driven by the handle.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public int GetEdgeNumber()
Visual Basic
Public Function GetEdgeNumber As Integer
Visual C++
public:
int GetEdgeNumber()

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsInvalidOperationException RebarConstrainedHandle is no longer valid. -or- The RebarConstrainedHandle is not of RebarHandleType 'Edge'.

See Also