Entity Constructor (Schema)


Creates a new Entity corresponding to the Schema.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public Entity(
	Schema schema
)
Visual Basic
Public Sub New ( _
	schema As Schema _
)
Visual C++
public:
Entity(
	Schema^ schema
)

Remarks

You can store the newly created Entity in an Element or in another Entity. If you do not have write access to the Schema, an exception will be thrown.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException Writing of Entities of this Schema is not allowed to the current add-in.

See Also