Entity Constructor (Schema)


Entity(Schema) Constructor

Creates a new Entity corresponding to the Schema.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Entity(
	Schema schema
)

Parameters

schema Schema
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
InvalidOperationException Writing of Entities of this Schema is not allowed to the current add-in.
Remarks
You can store the newly created Entity in an Element or in another Entity. If you do not have write access to the Schema, an exception will be thrown.
See Also