SetCategoryOverrides Method


Sets graphic overrides for a category in view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public void SetCategoryOverrides(
	ElementId categoryId,
	OverrideGraphicSettings overrideGraphicSettings
)
Visual Basic
Public Sub SetCategoryOverrides ( _
	categoryId As ElementId, _
	overrideGraphicSettings As OverrideGraphicSettings _
)
Visual C++
public:
void SetCategoryOverrides(
	ElementId^ categoryId, 
	OverrideGraphicSettings^ overrideGraphicSettings
)

Parameters

categoryId
Type: Autodesk.Revit.DBElementId
Category to be overridden
overrideGraphicSettings
Type: Autodesk.Revit.DBOverrideGraphicSettings
Object representing all graphic overrides of the category categoryId in view.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException Category cannot be overridden. -or- Fill pattern must be a drafting pattern. -or- Fill pattern Id must be invalidElementId or point to a LinePattern element.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException The view type does not support Visibility/Graphics Overriddes.

See Also