View Set |
Sets graphic overrides for a category in view.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public void SetCategoryOverrides(
ElementId categoryId,
OverrideGraphicSettings overrideGraphicSettings
)
Parameters
- categoryId ElementId
- Category to be overridden
- overrideGraphicSettings OverrideGraphicSettings
- Object representing all graphic overrides of the category categoryId in view.

Exception | Condition |
---|---|
ArgumentException | Category cannot be overridden. -or- Fill pattern must be a drafting pattern. -or- Fill pattern Id must be invalidElementId or point to a LinePattern element. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | The view type does not support Visibility/Graphics Overriddes. |