NewPointOnEdgeEdgeIntersection Method


Construct a PointOnEdgeEdgeIntersection object which is used to define the placement of a ReferencePoint given two references to edge.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public PointOnEdgeEdgeIntersection NewPointOnEdgeEdgeIntersection(
	Reference edgeReference1,
	Reference edgeReference2
)
Visual Basic
Public Function NewPointOnEdgeEdgeIntersection ( _
	edgeReference1 As Reference, _
	edgeReference2 As Reference _
) As PointOnEdgeEdgeIntersection
Visual C++
public:
PointOnEdgeEdgeIntersection^ NewPointOnEdgeEdgeIntersection(
	Reference^ edgeReference1, 
	Reference^ edgeReference2
)

Parameters

edgeReference1
Type: Autodesk.Revit.DBReference
The first edge reference.
edgeReference2
Type: Autodesk.Revit.DBReference
The second edge reference.

Return Value

A new PointOnEdgeEdgeIntersection object.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException Thrown when the input argument edgeReference1 or edgeReference2 is a null reference (Nothing in Visual Basic).

See Also