IsBuiltInCategory Method


Checks whether a ForgeTypeId identifies a built-in category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2022

Syntax

C#
public static bool IsBuiltInCategory(
	ForgeTypeId categoryTypeId
)
Visual Basic
Public Shared Function IsBuiltInCategory ( _
	categoryTypeId As ForgeTypeId _
) As Boolean
Visual C++
public:
static bool IsBuiltInCategory(
	ForgeTypeId^ categoryTypeId
)

Parameters

categoryTypeId
Type: Autodesk.Revit.DBForgeTypeId
The identifier to check.

Return Value

True if the ForgeTypeId identifies a built-in category, false otherwise.

Remarks

A ForgeTypeId identifies a built-in category if it corresponds to a valid BuiltInCategory value according to Category.IsBuiltInCategoryValid(BuiltInCategory) and Category.GetBuiltInCategoryTypeId(BuiltInCategory).

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also