Category Is |
Checks whether a ForgeTypeId identifies a built-in category.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- categoryTypeId ForgeTypeId
- The identifier to check.
Return Value
BooleanTrue if the ForgeTypeId identifies a built-in category, false otherwise.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

A ForgeTypeId identifies a built-in category if it corresponds to a valid BuiltInCategory value according to Category.IsBuiltInCategoryValid(BuiltInCategory) and Category.GetBuiltInCategoryTypeId(BuiltInCategory) .