Creates a new PathReinforcement object from an array of curves and given Rebar Shape id.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document.
- hostElement
- Type: Autodesk.Revit.DBElement
The element that will host the PathReinforcement. The host can be a Structural Floor, Structural Wall, Structural Slab, or a Part created from a structural layer belonging to one of those element types.
- curveArray
- Type: System.Collections.GenericIListCurve
An array of curves that will define the outline of the PathReinforcement.
- flip
- Type: SystemBoolean
A flag controlling the bars relative to the curves.
- pathReinforcementTypeId
- Type: Autodesk.Revit.DBElementId
The id of the PathReinforcementType.
- rebarBarTypeId
- Type: Autodesk.Revit.DBElementId
The id of the RebarBarType.
- startRebarHookTypeId
- Type: Autodesk.Revit.DBElementId
The id of the RebarHookType for the start of the bar. If this parameter is InvalidElementId, it means to create a rebar with no start hook.
- endRebarHookTypeId
- Type: Autodesk.Revit.DBElementId
The id of the RebarHookType for the end of the bar. If this parameter is InvalidElementId, it means to create a rebar with no end hook.
- rebarShapeId
- Type: Autodesk.Revit.DBElementId
The id of the RebarShape element that defines the shape of the rebars in the object.
Return Value
The newly created PathReinforcement.Remarks
The method sets Rebar Shape of primary bars only.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The input curveArray is empty. -or- The input curveArray contains at least one helical curve and is not supported for this operation. -or- The element hostElement was not found in the given document. -or- the host Element is not a valid host for Area Reinforcement, Path Reinforcement, Fabric Area or Fabric Sheet. -or- The structural rebar is not within area and path reinforcement. -or- curves in curveArray are not continuous and open. -or- pathReinforcementTypeId should refer to an Path Reinforcement Type element. -or- rebarBarTypeId should refer to an RebarBarType element. -or- startRebarHookTypeId should be invalid or refer to an RebarHookType element. -or- endRebarHookTypeId should be invalid or refer to an RebarHookType element. -or- rebarShapeId should refer to two dimensional Rebar Shape element with segments forming only right angles. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsArgumentsInconsistentException | startRebarHookTypeId cannot be set for given rebar shape. -or- endRebarHookTypeId cannot be set for given rebar shape. |
Autodesk.Revit.ExceptionsForbiddenForDynamicUpdateException | This method may not be called during dynamic update. |