Create Method (Document, Element, IList(Curve), Boolean, ElementId, ElementId, ElementId, ElementId, ElementId)


Path Reinforcement Create(Document, Element, IList Curve , Boolean, Element Id, Element Id, Element Id, Element Id, Element Id) Method

Creates a new PathReinforcement object from an array of curves and given Rebar Shape id.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static PathReinforcement Create(
	Document document,
	Element hostElement,
	IList<Curve> curveArray,
	bool flip,
	ElementId pathReinforcementTypeId,
	ElementId rebarBarTypeId,
	ElementId startRebarHookTypeId,
	ElementId endRebarHookTypeId,
	ElementId rebarShapeId
)

Parameters

document Document
The document.
hostElement Element
The element that will host the PathReinforcement. The host can be a Structural Floor, Structural Wall, Structural Slab, or a Part created from a structural layer belonging to one of those element types.
curveArray IList Curve
An array of curves that will define the outline of the PathReinforcement.
flip Boolean
A flag controlling the bars relative to the curves.
pathReinforcementTypeId ElementId
The id of the PathReinforcementType.
rebarBarTypeId ElementId
The id of the RebarBarType.
startRebarHookTypeId ElementId
The id of the RebarHookType for the start of the bar. If this parameter is InvalidElementId, it means to create a rebar with no start hook.
endRebarHookTypeId ElementId
The id of the RebarHookType for the end of the bar. If this parameter is InvalidElementId, it means to create a rebar with no end hook.
rebarShapeId ElementId
The id of the RebarShape element that defines the shape of the rebars in the object.

Return Value

PathReinforcement
The newly created PathReinforcement.
Exceptions
Exception Condition
ArgumentException The input curveArray is empty. -or- The input curveArray contains at least one helical curve and is not supported for this operation. -or- The element hostElement was not found in the given document. -or- the host Element is not a valid host for Area Reinforcement, Path Reinforcement, Fabric Area or Fabric Sheet. -or- The structural rebar is not within area and path reinforcement. -or- curves in curveArray are not continuous and open. -or- pathReinforcementTypeId should refer to an Path Reinforcement Type element. -or- rebarBarTypeId should refer to an RebarBarType element. -or- startRebarHookTypeId should be invalid or refer to an RebarHookType element. -or- endRebarHookTypeId should be invalid or refer to an RebarHookType element. -or- rebarShapeId should refer to two dimensional Rebar Shape element with segments forming only right angles.
ArgumentNullException A non-optional argument was null
ArgumentsInconsistentException startRebarHookTypeId cannot be set for given rebar shape. -or- endRebarHookTypeId cannot be set for given rebar shape.
ForbiddenForDynamicUpdateException This method may not be called during dynamic update.
Remarks
The method sets Rebar Shape of primary bars only.
See Also