SchedulableField Constructor (ScheduleFieldType)


Creates a new SchedulableField.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public SchedulableField(
	ScheduleFieldType fieldType
)
Visual Basic
Public Sub New ( _
	fieldType As ScheduleFieldType _
)
Visual C++
public:
SchedulableField(
	ScheduleFieldType fieldType
)

Parameters

fieldType
Type: Autodesk.Revit.DBScheduleFieldType
The type of data displayed by the field.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException fieldType is not a schedulable field type -or- The fieldType can't be CustomField. To create a CustomField, you should use the constructor which receives the custom field server id as a parameter.
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also