GetResolutionCaption Method


Retrieves the caption for a specific resolution type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public string GetResolutionCaption(
	FailureResolutionType type
)
Visual Basic
Public Function GetResolutionCaption ( _
	type As FailureResolutionType _
) As String
Visual C++
public:
String^ GetResolutionCaption(
	FailureResolutionType type
)

Parameters

type
Type: Autodesk.Revit.DBFailureResolutionType
The resolution type.

Return Value

The caption of the resolution.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException Resolution of the type is not applicable to the failure.
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.ExceptionsInvalidOperationException FailureDefinition does not have any resolutions.

See Also