GetResolutionCaption Method


Failure Definition Get Resolution Caption Method

Retrieves the caption for a specific resolution type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public string GetResolutionCaption(
	FailureResolutionType type
)

Parameters

type FailureResolutionType
The resolution type.

Return Value

String
The caption of the resolution.
Exceptions
Exception Condition
ArgumentException Resolution of the type is not applicable to the failure.
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException FailureDefinition does not have any resolutions.
See Also