Checks that all arcs in the chain of curves have radii that are not less than minimum bend radius for bar type and style
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2009
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- curves
- Type: System.Collections.GenericIListCurve
An array of curves intended to define the shape of the rebar curves. Bends and hooks should not be included in the array of curves.
- style
- Type: Autodesk.Revit.DB.StructureRebarStyle
The usage of the bar, "standard" or "stirrup/tie".
- barType
- Type: Autodesk.Revit.DB.StructureRebarBarType
A RebarBarType element that defines bar diameter, bend radius and material of the rebar.
Return Value
Returns true if all arc bend radii are not less than minimum bend radius for bar type and styleExceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |