ContainsValidArcRadiiForStyleAndBarType Method


Rebar Contains Valid Arc Radii For Style And Bar Type Method

Checks that all arcs in the chain of curves have radii that are not less than minimum bend radius for bar type and style

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool ContainsValidArcRadiiForStyleAndBarType(
	IList<Curve> curves,
	RebarStyle style,
	RebarBarType barType
)

Parameters

curves IList Curve
An array of curves intended to define the shape of the rebar curves. Bends and hooks should not be included in the array of curves.
style RebarStyle
The usage of the bar, "standard" or "stirrup/tie".
barType RebarBarType
A RebarBarType element that defines bar diameter, bend radius and material of the rebar.

Return Value

Boolean
Returns true if all arc bend radii are not less than minimum bend radius for bar type and style
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also