MoveBarInSet Method


This method applies the transformation matrix to the rebar bar at the desired position in the rebar set. If the bar was already moved, the method will concatenate the transformation matrix with the existing movement.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2022

Syntax

C#
public void MoveBarInSet(
	int barPositionIndex,
	Transform moveTransform
)
Visual Basic
Public Sub MoveBarInSet ( _
	barPositionIndex As Integer, _
	moveTransform As Transform _
)
Visual C++
public:
void MoveBarInSet(
	int barPositionIndex, 
	Transform^ moveTransform
)

Parameters

barPositionIndex
Type: SystemInt32
The bar index of the rebar to apply the transformation.
moveTransform
Type: Autodesk.Revit.DBTransform
The transformation matrix to apply to the specified rebar bar.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException barPositionIndex is not in the range [ 0, NumberOfBarPositions-1 ].

See Also