Rebar
Move
|
This method applies the transformation matrix to the rebar bar at the desired position in the rebar set.
If the bar was already moved, the method will concatenate the transformation matrix with the existing movement.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)

Parameters
- barPositionIndex Int32
- The bar index of the rebar to apply the transformation.
- moveTransform Transform
- The transformation matrix to apply to the specified rebar bar.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | barPositionIndex should be in range [ 0, NumberOfBarPositions-1 ] and the bar at barPositionIndex should be included. -or- moveTransform is not conformal. |