FamilyInstanceCreationData Constructor (XYZ, FamilySymbol, XYZ, Element, StructuralType)


Initializes a new instance of the FamilyInstanceCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyInstanceCreationData(
	XYZ location,
	FamilySymbol symbol,
	XYZ referenceDirection,
	Element host,
	StructuralType structuralType
)
Visual Basic
Public Sub New ( _
	location As XYZ, _
	symbol As FamilySymbol, _
	referenceDirection As XYZ, _
	host As Element, _
	structuralType As StructuralType _
)
Visual C++
public:
FamilyInstanceCreationData(
	XYZ^ location, 
	FamilySymbol^ symbol, 
	XYZ^ referenceDirection, 
	Element^ host, 
	StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.DBXYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.DBFamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
referenceDirection
Type: Autodesk.Revit.DBXYZ
A vector that dictates the direction of certain family instances.
host
Type: Autodesk.Revit.DBElement
The object into which the FamilyInstance is to be inserted, often known as the host.
structuralType
Type: Autodesk.Revit.DB.StructureStructuralType
If structural then specify the type of the component.

See Also