Family |
Initializes a new instance of the FamilyInstanceCreationData class
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public FamilyInstanceCreationData(
XYZ location,
FamilySymbol symbol,
XYZ referenceDirection,
Element host,
StructuralType structuralType
)
Parameters
- location XYZ
- The physical location where the instance is to be placed.
- symbol FamilySymbol
- A FamilySymbol object that represents the type of the instance that is to be inserted.
- referenceDirection XYZ
- A vector that dictates the direction of certain family instances.
- host Element
- The object into which the FamilyInstance is to be inserted, often known as the host.
- structuralType StructuralType
- If structural then specify the type of the component.