GetConditionName Method


Gets the name of the specified condition on the fabrication service button.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2016

Syntax

C#
public string GetConditionName(
	int condition
)
Visual Basic
Public Function GetConditionName ( _
	condition As Integer _
) As String
Visual C++
public:
String^ GetConditionName(
	int condition
)

Parameters

condition
Type: SystemInt32
The condition index.

Return Value

The name of the specified condition on the fabrication service button.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException The index condition is not larger or equal to 0 and less than ConditionCount.

See Also