CreatePlaceholder Method


Pipe Create Placeholder Method

Creates a new placeholder pipe.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static Pipe CreatePlaceholder(
	Document document,
	ElementId systemTypeId,
	ElementId pipeTypeId,
	ElementId levelId,
	XYZ startPoint,
	XYZ endPoint
)

Parameters

document Document
The document.
systemTypeId ElementId
The ElementId of the piping system type.
pipeTypeId ElementId
The ElementId of the pipe type.
levelId ElementId
The level id for the pipe.
startPoint XYZ
The first point of the placeholder line.
endPoint XYZ
The second point of the placeholder line.

Return Value

Pipe
The placeholder pipe.
Exceptions
Exception Condition
ArgumentException The systemTypeId is not valid piping system type. -or- The pipe type pipeTypeId is not valid pipe type. -or- The ElementId levelId is not a Level. -or- The points of startPoint and endPoint are too close: for MEPCurve, the minimum length is 1/10 inch.
ArgumentNullException A non-optional argument was null
See Also