Create Method (XYZ, XYZ)


Constructs a BRepBuilderEdgeGeometry representing a straight line between the two given points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2016

Syntax

C#
public static BRepBuilderEdgeGeometry Create(
	XYZ startPoint,
	XYZ endPoint
)
Visual Basic
Public Shared Function Create ( _
	startPoint As XYZ, _
	endPoint As XYZ _
) As BRepBuilderEdgeGeometry
Visual C++
public:
static BRepBuilderEdgeGeometry^ Create(
	XYZ^ startPoint, 
	XYZ^ endPoint
)

Parameters

startPoint
Type: Autodesk.Revit.DBXYZ
endPoint
Type: Autodesk.Revit.DBXYZ

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentsInconsistentException The vectors startPoint and endPoint are coincident.

See Also